Actin Install and Build - Ubuntu

This video will show you how to install Actin and build the examples with CMake. It's assumed that you've already downloaded the install file.

Note: When installing, you'll also need to install the package dependencies before running Actin. See the 2nd video on this page.

Package Dependencies

Errata: When running the package installer sudo apt-get install, remove libjpeg9-dev from the list. It causes a dependency conflict - like the message below. This is a known problem in Ubuntu 18.04.

Unpacking libjpeg9-dev:amd64 (1:9b-2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-rsA5f2/115-libjpeg9-dev_1%3a9b-2_amd64.deb (--unpack):
 trying to overwrite '/usr/include/jerror.h', which is also in package libjpeg-turbo8-dev:amd64 1.5.2-0ubuntu5.18.04.3